Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: macOS Sierra 10.12

macOS Sierra 10.12 30 Ago. 2018 10:14 #12824

  • cneves001
  • Avatar de cneves001
  • Offline
  • Mensagens: 5
  • Obrigado recebido 2
Sim. Executei esse procedimento e não resolveu o problema, nem tão pouco removeu todas as instalações do JAVA existentes no meu SO.

Com o procedimento que falo, resolve o problema.
O adminstrador desactivou a escrita pública.
The following user(s) said Thank You: marcolopes

macOS Sierra 10.12 30 Ago. 2018 05:41 #12823

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5331
  • Obrigado recebido 741
cneves001 escreveu:
Em conclusão, quando se usa o procedimento para desinstalar o Java, que está disponível no site da Oracle, a verdade é que é uma desinstalação virtual, no código as instalações das várias versões mantêm-se na mesma, só desaparece das preferências. Ora, com os comandos que eu referi resulta, porque são mesmo removidas as instalações das várias versões do Java.

Fala deste procedimento descrito aqui? www.java.com/en/download/help/mac_uninstall_java.xml
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

macOS Sierra 10.12 29 Ago. 2018 13:43 #12820

  • cneves001
  • Avatar de cneves001
  • Offline
  • Mensagens: 5
  • Obrigado recebido 2
Olá Marco,

tenho novidades, já consegui resolver o problema, porém tudo o que me aconselhou a fazer eu fiz e não resolveu o problema, mas após várias tentativas para a resolução do problema consegui finalmente perceber a razão e solucionar o erro, passo a explicar:

Como eu já tinha referido, a minha versão do SO é 10.13.6 High Sierra, com JAVA JRE 8 e Colibri RCP 12.3.0.3 a funcionar na perfeição, entretanto resolvi instalar o Eclipse Reporting Photon, para editar os templates do Colibri, quando tentei abrir a aplicação do Eclipse recebi uma mensagem de erro e não arrancava, tentei pesquisar sobre o assunto e verifiquei que se tratava do Java JDK, era preciso instalar este pacote de software e depois de eu o instalar, última versão, o Eclipse já não dava erro e arrancava, só que deixou de funcionar o Colibri, desinstalei todos os pacotes do Java, voltei a instalar os paks originais e o erro do Colibri mantinha-se.

Após várias tentativas, lembrei-me de desinstalar o Java via consola (Terminal) e usei os comandos:

java -version (comando para listar a versão do Java instalada)
ls (listar todas as versões do Java instaladas na máquina)
sudo rm -rf (comando para remover a versão do Java que pretendermos)

Aqui vai um exemplo do que tive de apagar:
Last login: Tue Aug 28 21:54:06 on xxxxxx
MAC:~ user$ java -version
java version "10.0.2" 2018-07-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.2+13)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)
MAC:~ user$ cd /Library/Java/JavaVirtualMachines
MAC:JavaVirtualMachines user$ ls
1.6.0.jdk		
jdk1.7.0_80.jdk
jdk1.8.0_181.jdk
jdk-10.0.2.jdk		
MAC:JavaVirtualMachines user$ sudo rm -rf jdk-10.0.2.jdk
MAC:JavaVirtualMachines user$ sudo rm -rf jdk1.7.0_80.jdk
MAC:JavaVirtualMachines user$ sudo rm -rf jdk1.8.0_181.jdk
MAC:JavaVirtualMachines user$ ls
1.6.0.jdk
MAC:JavaVirtualMachines user$ ls
1.6.0.jdk	
jdk-10.0.2.jdk
MAC:JavaVirtualMachines user$ sudo rm -rf jdk-10.0.2.jdk
Password:
MAC:JavaVirtualMachines user$

Depois de desinstalar todas as versões do Java, tive de instalar a versão original do Java da Apple, via site da Apple, que é a versão 6 e só depois instalei a versão 8 e o Colibri já arrancou sem problemas (: (:, depois instalei o JDK versão 10 e atualmente tenho tudo a funcionar na perfeição.

Em conclusão, quando se usa o procedimento para desinstalar o Java, que está disponível no site da Oracle, a verdade é que é uma desinstalação virtual, no código as instalações das várias versões mantêm-se na mesma, só desaparece das preferências. Ora, com os comandos que eu referi resulta, porque são mesmo removidas as instalações das várias versões do Java.

Espero ter ajudado.

Abraço
Última Edição: 30 Ago. 2018 13:30 por marcolopes.
O adminstrador desactivou a escrita pública.
The following user(s) said Thank You: marcolopes

macOS Sierra 10.12 28 Ago. 2018 13:50 #12816

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5331
  • Obrigado recebido 741
cneves001 escreveu:
Sem dúvida, a única alteração foi eu ter substituído a minha versão do Java JRE 8 pela JRE10, só depois desta operação é que deixou de funcionar e tentei fazer o downgrade e sem sucesso desde então e naturalmente em stress porque preciso de emitir documentos.....

Vou fazer tentativas com outras versões do Java e ver o que dá.

Se não conseguir faça o seguinte:

Mantenha a versão mais actualizada do JAVA 10 instalado no sistema (para acesso geral das aplicações) e faça download do JAVA 7 ou 8, colocando-o na PASTA de instalação do COLIBRI, por exemplo. Depois terá de editar o ficheiro INI que se encontra na pasta de instalação do Colibri e inserir o seguinte:

-vm
/Applications/ProjectoColibri12/java/.../bin


(ajustar "java/.../bin" com o caminho completo da pasta BIN do JAVA)

De qualquer forma gostaria de chegar a uma conclusão sobre as razões de, após a instalação do JAVA 10 no sistema, o colibri deixa de funcionar se voltar a ser instalado o JAVA 8!!
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 28 Ago. 2018 13:51 por marcolopes.
O adminstrador desactivou a escrita pública.

macOS Sierra 10.12 28 Ago. 2018 13:39 #12814

  • cneves001
  • Avatar de cneves001
  • Offline
  • Mensagens: 5
  • Obrigado recebido 2
Sem dúvida, a única alteração foi eu ter substituído a minha versão do Java JRE 8 pela JRE10, só depois desta operação é que deixou de funcionar e tentei fazer o downgrade e sem sucesso desde então e naturalmente em stress porque preciso de emitir documentos.....

Vou fazer tentativas com outras versões do Java e ver o que dá.

Abraço
O adminstrador desactivou a escrita pública.

macOS Sierra 10.12 28 Ago. 2018 13:34 #12813

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5331
  • Obrigado recebido 741
cneves001 escreveu:
Quando instalei a aplicação Eclipse, não conseguia arrancar com a mesma, aparecia um erro a informar que tinha de ter uma versão do Java mais recente e a verdade é que eu já tinha a versão mais recente, Java 8, então resolvi instalar o JRE 10 Development, e depois de instalar essa versão o Eclipse passou a funcionar, só depois reparei quando quis abrir o RCP Colibri que deixou de funcionar, mas repito já esteve a funcionar com o Java JRE 8.

Muito estranho ter deixado de funcionar após ter instalado o Eclipse, uma vez que o eclipse não é mais do que uma pasta, e não interfere em absolutamente nada nas outras aplicações, e também não altera qualquer configuração no sistema...
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 28 Ago. 2018 13:46 por marcolopes.
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes
Desenvolvido por Kunena