Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar
  • Página:
  • 1
  • 2

TÓPICO: Erro ao iniciar o programa

Erro ao iniciar o programa 18 Out. 2018 19:27 #12875

  • umadesign
  • Avatar de umadesign
  • Offline
  • Mensagens: 2
  • Obrigado recebido 1
Problema resolvido, depois de ler esta resposta.

Tinha o java a apontar para o jdk 11.

Adicionei no início do ficheiro RCPcolibri.ini o seguinte:
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/bin

O path para o jdk foi obtido com o comando /usr/libexec/java_home -V
O adminstrador desactivou a escrita pública.
The following user(s) said Thank You: marcolopes

Erro ao iniciar o programa 18 Out. 2018 17:32 #12874

  • umadesign
  • Avatar de umadesign
  • Offline
  • Mensagens: 2
  • Obrigado recebido 1
Boa tarde,

Estou com o mesmo erro do michael_pt.

MacOS High Sierra
Java 8 Update 181

Há alguma forma de resolver isto?

Obrigado
O adminstrador desactivou a escrita pública.

Erro ao iniciar o programa 16 Jan. 2018 02:20 #12383

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5312
  • Obrigado recebido 735
phaiser escreveu:
Tenho um erro diferente.
Tenho a versão 10 (gratuita) e estava actualizar agora para a versão 12.
- Fiz o download da versão 12
- Instalei conforme indicações do .dmg (mover pasta para Applications)
- Movi as db h2 e alterei o nome de colibri10 para colibri12
- Ao abrir tenho o seguinte erro:
The RCPcolibri executable launcher was unable to locate its
companion shared library.

Problema discutido aqui: www.projectocolibri.com/forum/sistema-op...-10-12?start=6#12257
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

Erro ao iniciar o programa 15 Jan. 2018 18:49 #12382

  • phaiser
  • Avatar de phaiser
  • Offline
  • Mensagens: 10
  • Obrigado recebido 3
Tenho um erro diferente.
Tenho a versão 10 (gratuita) e estava actualizar agora para a versão 12.

- Fiz o download da versão 12
- Instalei conforme indicações do .dmg (mover pasta para Applications)
- Movi as db h2 e alterei o nome de colibri10 para colibri12
- Ao abrir tenho o seguinte erro:
The RCPcolibri executable launcher was unable to locate its
companion shared library.

Ao pensar que podia ser de alguma base de dados, resolvi apagar tudo e instalar novamente, abrindo sem alteração das DB e obtenho o mesmo erro.

Tenho o java 8 update 151
MacOS High Sierra 10.13.2
O adminstrador desactivou a escrita pública.

Erro ao iniciar o programa 09 Jan. 2018 21:11 #12372

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5312
  • Obrigado recebido 735
michael_pt escreveu:
Boas,
após update para o Java 9... o colibri CAPUT

Bugs do JAVA 9! O Colibri está testado com o Java 8! Aconselhamos até o JAVA 7!
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

Erro ao iniciar o programa 09 Jan. 2018 19:34 #12371

  • michael_pt
  • Avatar de michael_pt
  • Offline
  • Mensagens: 1
Boas,

após update para o Java 9... o colibri CAPUT
HELP!!!

Obrigado.
ENTRY org.eclipse.equinox.common 4 0 2018-01-09 18:25:04.981
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.common_3.6.100.v20120522-1841 [92]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Última Edição: 09 Jan. 2018 21:11 por marcolopes.
O adminstrador desactivou a escrita pública.
  • Página:
  • 1
  • 2
Moderadores: marcolopes
Desenvolvido por Kunena