Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: Instalação do Visualizador RCP

Instalação do Visualizador RCP 2 anos 4 meses atrás #9378

  • dgomes
  • Avatar de dgomes
  • DESLIGADO
  • Mensagens: 5
Olá,

Estou com problemas na instalação do Visualizador RCP no Ubuntu.

Já alterei os "caminhos" para o xulrunner e mesmo assim o Visualizador não abre nem gera erro.

Corri no terminal o ficheiro RCPvisualizador e encontrei o seguinte erro:
Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /home/UTILIZADOR/Colibri/Visualizador RCP Linux (x86)/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.

Pelo que percebi numa rápida pesquisa, poderá estar relacionado com a versão do eclipse nas livrarias do Visualizador ser a de 32bit.

Existe forma de contornar esta questão ou o Visualizador só corre em 32bit?

Sistema Operativo: Ubuntu 14.04 64Bits
Versão do Visualizador: Não a consigo detectar (download efectuado a 02/04/2015)
Motor de base de dados: H2
Última Edição: 2 anos 4 meses atrás por dgomes.
O adminstrador desactivou a escrita pública.

Instalação do Visualizador RCP 2 anos 3 meses atrás #9489

  • marcolopes
  • Avatar de marcolopes
  • DESLIGADO
  • Mensagens: 4765
  • Obrigado recebido 658
dgomes escreveu:
Estou com problemas na instalação do Visualizador RCP no Ubuntu.
Já alterei os "caminhos" para o xulrunner e mesmo assim o Visualizador não abre nem gera erro.

Aconselho uma leitura deste tópico: www.projectocolibri.com/forum/14-FAQ-Per...cto-colibri-em-linux
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

Instalação do Visualizador RCP 2 anos 3 meses atrás #9490

  • dgomes
  • Avatar de dgomes
  • DESLIGADO
  • Mensagens: 5
Reli o tópico e todos os procedimentos foram efetuados.

A única diferença é o ficheiro libwebkitgtk-1.0-0 que não pode ser removido porque o software GnuCash depende do mesmo.

Existe alguma forma de corrigir a incompatibilidade entre o Visualizador e o libwebkitgtk-1.0-0?

Em relação ao Colibri, resolvi colocando a livraria 64x do XULRUNNER, será que esta livaria terá de ser 32x para o Visualizador?

Obrigado pela atenção.
O adminstrador desactivou a escrita pública.

Instalação do Visualizador RCP 2 anos 3 meses atrás #9491

  • dgomes
  • Avatar de dgomes
  • DESLIGADO
  • Mensagens: 5
Reli o tópico e todos os procedimentos foram efetuados.

A única diferença é o ficheiro libwebkitgtk-1.0-0 que não pode ser removido porque o software GnuCash depende do mesmo.

Existe alguma forma de corrigir a incompatibilidade entre o Visualizador e o libwebkitgtk-1.0-0?

Em relação ao Colibri, resolvi colocando a livraria 64x do XULRUNNER, será que esta livraria terá de ser 32x para o Visualizador?

Obrigado pela atenção.
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes