Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: O programa vai abaixo

O programa vai abaixo 26 Jan. 2015 01:16 #8942

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5312
  • Obrigado recebido 735
Aconselhamos a leitura do seguinte tópico a todos os utilizadores que se deparem com problemas técnicos na instalação / utilização do Colibri em Linux: www.projectocolibri.com/forum/14-FAQ-Per...cto-colibri-em-linux
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

O programa vai abaixo 12 Fev. 2014 16:22 #7445

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5312
  • Obrigado recebido 735
fidalgo escreveu:
@marcolopes: Descobri porque é que nas versões mais recentes das distribuições o colibri deixa de funcionar.
Deve-se a uma atualização do WebkitGTK, que para o colibri funcionar deve ser a versão 1.1x e nas ultimas distribuições vem a versão 2.2.4.

Muito obrigado pela info. Toda a ajuda é preciosa.

As infos oficiais indicam que as versões superiores "devem" ser compatíveis: www.eclipse.org/swt/faq.php#browserlinux
Eclipse 3.7.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x and 3.6.x (but not 2.x), WebKitGTK+ 1.2.x and newer

Fizemos um upgrade para a plataforma Eclipse 3.8, mas não irá alterar este cenário, uma vez que a info é a mesma:
Eclipse 3.8.x: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x, 3.6.x and 10.x (but not 2.x nor 4.x - 9.x), WebKitGTK+ 1.2.x and newer

Se tiver tempo p.f. leia os seguintes tópicos e diga-me se as suspeitas estão confirmadas algures:
bugs.eclipse.org/bugs/show_bug.cgi?id=420030
bugs.eclipse.org/bugs/show_bug.cgi?id=334466
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 12 Fev. 2014 16:52 por marcolopes.
O adminstrador desactivou a escrita pública.

O programa vai abaixo 12 Fev. 2014 09:13 #7442

  • fidalgo
  • Avatar de fidalgo
  • Offline
  • Mensagens: 26
  • Obrigado recebido 12
@marcolopes: Descobri porque é que nas versões mais recentes das distribuições o colibri deixa de funcionar.

Deve-se a uma atualização do WebkitGTK, que para o colibri funcionar deve ser a versão 1.1x e nas ultimas distribuições vem a versão 2.2.4.

Entretanto para Fedora 20 criei um RPM, instalei e o software funciona sem nenhum problema.

Penso que do lado do projecto, apenas seria necessário alterar a dependencia do SWT para uma versão superior, dado que houve correções neste campo. No entanto, como não tenho acesso ao código não posso comprovar :)

Se mais alguém quiser usar o Fedora Linux na versão 20, enviem-me uma mensagem privada a pedir o RPM.
O adminstrador desactivou a escrita pública.
The following user(s) said Thank You: marcolopes

O programa vai abaixo 05 Fev. 2014 17:09 #7411

  • fidalgo
  • Avatar de fidalgo
  • Offline
  • Mensagens: 26
  • Obrigado recebido 12
ArturCorreia: Pode deixar quais as versões do Ubuntu e Kubuntu que usa?

As distribuições mais recentes parecem ter problemas... com o pacote webkit
C  [libsoup-2.4.so.1+0x6dab1]  soup_session_feature_detach+0x11

em que esta libsoup é uma dependencia.

No caso do Fedora só consigo usar até à versão 18, que já foi descontinuada.
O adminstrador desactivou a escrita pública.

O programa vai abaixo 06 Jan. 2014 10:35 #7150

  • arturcorreia
  • Avatar de arturcorreia
  • Offline
  • Mensagens: 3
  • Obrigado recebido 1
isto não gera log nenhum
de qualquer modo, confirmo que é um problema com algum pacote na minha configuração. só não consigo perceber qual.
instalei noutros dois computadores com linux. num crasha, noutro não.
a única diferença é que os que crasham correm ambos kubuntu; o que não crasha corre ubuntu. a avaliar por vários foruns, fico com a sensação que é um problema relacionado com o gtk2
vou usar o computador onde não crasha.
obrigado
O adminstrador desactivou a escrita pública.

O programa vai abaixo 05 Jan. 2014 17:39 #7149

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5312
  • Obrigado recebido 735
arturcorreia escreveu:
Afinal não resolvi nada. o programa parecia ir abaixo quando tentava gravar na base de dados. na primeira utilização com a modificação das permissões não houve problema nenhum. quando voltei a arrancar voltou a ir abaixo. já instalei com o driver MySql (as tabelas são criadas com sucesso), mas depois não consigo fazer mais nada. Sempre que é necessário escrever para a base de dados, "crasha".

Coloque aqui o LOG gerado: www.projectocolibri.com/forum/2-Bem-Vind...-UM-NOVO-T%C3%93PICO
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes
Desenvolvido por Kunena