Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: Erro de Java OpenJDK

Erro de Java OpenJDK 18 Dez. 2013 19:09 #7081

  • valeptb@gmail.com
  • Avatar de valeptb@gmail.com
  • Offline
  • Mensagens: 2
Quando inicio o Colibri 9.2.0 e depois de fazer o login, quando inicia o carregamento da aplicação termina abruptamente e gera o logo em cima.
É a minha primeira vez com o Colibri.
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f464431ac91, pid=21731, tid=139942069413632
#
# JRE version: Java(TM) SE Runtime Environment (7.0_45-b18) (build 1.7.0_45-b18)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libsoup-2.4.so.1+0x6ac91]  soup_session_feature_detach+0x11
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Última Edição: 21 Dez. 2013 18:18 por marcolopes.
O adminstrador desactivou a escrita pública.

Erro de Java OpenJDK 16 Out. 2013 17:59 #6624

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5496
  • Obrigado recebido 763
fidalgo escreveu:
Mesmo resultado no mesmo sitio

Está confirmado então. De qualquer forma não temos solução para esse problema, pois a migração para Eclipse 4 está fora de questão num futuro próximo, e já agora explico as razões:

O Eclipse 4 é uma plataforma bastante diferente no seu "core" (nomeadamente UI), e embora ofereça uma "camada de compatibilidade" cujo propósito é permitir uma migração sem grandes complicações (que quanto a mim, deve ser usada por produtos "legacy"), a verdade é que, muitas funcionalidades da tecnologia do Eclipse 3 deixam de funcionar MESMO com a tal camada de compatibilidade. Uma migração terá de ser pensada de acordo com esforço / benefício, e não apenas para resolver um ou outro problema que foi resolvido na nova plataforma.
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 16 Out. 2013 19:03 por marcolopes.
O adminstrador desactivou a escrita pública.

Erro de Java OpenJDK 16 Out. 2013 17:35 #6623

  • fidalgo
  • Avatar de fidalgo
  • Offline
  • Mensagens: 27
  • Obrigado recebido 12
marcolopes escreveu:
Mesmo assim, e como já foi dito neste tópico, vou-lhe pedir que remova o OpenJDK e instale o Oracle.
Em alternativa se, tiver os dois instalados:
- Execute o comando: update-alternatives --config java
- Defina o da JAVA Oracle por omissão
Dê-me o seu feedback.

Mesmo resultado no mesmo sitio:
#  SIGSEGV (0xb) at pc=0x00007f06316aea11, pid=1728, tid=139665015170816
#
# JRE version: Java(TM) SE Runtime Environment (7.0_45-b18) (build 1.7.0_45-b18)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libsoup-2.4.so.1+0x6da11]  soup_session_feature_detach+0x11
Última Edição: 16 Out. 2013 17:43 por marcolopes.
O adminstrador desactivou a escrita pública.

Erro de Java OpenJDK 16 Out. 2013 16:18 #6620

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5496
  • Obrigado recebido 763
fidalgo escreveu:
Sim uso o OpenJDK na versão 1.7.
De notar que esta é uma implementação de referência: blogs.oracle.com/henrik/entry/moving_to_openjdk_as_the
Como lhe disse o problema acontece devido a um upgrade da libsoup que é uma dependência do webkitGTK. Se testar com o fedora 18 funciona, com o 19 já não.

Mesmo assim, e como já foi dito neste tópico, vou-lhe pedir que remova o OpenJDK e instale o Oracle.

Em alternativa se, tiver os dois instalados:
- Execute o comando: update-alternatives --config java
- Defina o da JAVA Oracle por omissão

Dê-me o seu feedback.
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 16 Out. 2013 16:19 por marcolopes.
O adminstrador desactivou a escrita pública.

Erro de Java OpenJDK 16 Out. 2013 15:43 #6619

  • fidalgo
  • Avatar de fidalgo
  • Offline
  • Mensagens: 27
  • Obrigado recebido 12
Sim uso o OpenJDK na versão 1.7.

De notar que esta é uma implementação de referência: blogs.oracle.com/henrik/entry/moving_to_openjdk_as_the

Como lhe disse o problema acontece devido a um upgrade da libsoup que é uma dependência do webkitGTK. Se testar com o fedora 18 funciona, com o 19 já não.
O adminstrador desactivou a escrita pública.

Erro de Java OpenJDK 16 Out. 2013 15:26 #6618

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5496
  • Obrigado recebido 763
fidalgo escreveu:
De qualquer das formas o problema é no SWT, em que é usado na vossa classe CustomBrowser, pois com a atualização do webkitGTK, houve mudanças de API.

Qual é o JAVA que está a utilizar? OpenJDK ou Oracle?
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes
Desenvolvido por Kunena