Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: Upgrade 9.1.1 para 9.2.1

Upgrade 9.1.1 para 9.2.1 16 Ago. 2013 23:03 #6272

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5361
  • Obrigado recebido 745
paulinomt escreveu:
O Problema está resolvido.

Eu percebi pela sua resposta... O problema ficou resolvido depois de reinstalar o JAVA.

A questão aqui é que tinha feito uma pergunta por "pontos", para tentar chegar a uma conclusão lógica... e fiquei sem perceber porque teve problemas ao arrancar com a versão 9 do Colibri e não os teve com a versão ANTERIOR!!!
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 16 Ago. 2013 23:04 por marcolopes.
O tópico foi bloqueado.

Upgrade 9.1.1 para 9.2.1 16 Ago. 2013 13:51 #6271

  • paulinomt
  • Avatar de paulinomt
  • Offline
  • Mensagens: 3
Boa tarde Marco.

O Problema está resolvido.

Obrigado,
Manuel Paulino
Última Edição: 16 Ago. 2013 22:59 por marcolopes.
O tópico foi bloqueado.

Upgrade 9.1.1 para 9.2.1 16 Ago. 2013 13:33 #6270

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5361
  • Obrigado recebido 745
paulinomt escreveu:
Faço um ponto da situação, parece que o erro "Não é possível inicializar a persistência" têm com o arranque do Java VM e com a instalação do java, que no meu caso se passou, após a reinstalação do Java tudo funcionou.

Não conseguiu, portanto, concluír o PONTO 1.

Obrigado pelo feedback.
Marco Lopes
Gestor de projecto
Análise e Programação
O tópico foi bloqueado.

Upgrade 9.1.1 para 9.2.1 16 Ago. 2013 12:49 #6269

  • paulinomt
  • Avatar de paulinomt
  • Offline
  • Mensagens: 3
Boa tarde.


Faço um ponto da situação, parece que o erro "Não é possível inicializar a persistência" têm com o arranque do Java VM e com a instalação do java, que no meu caso se passou, após a reinstalação do Java tudo funcionou.

Obrigado.
Última Edição: 16 Ago. 2013 13:31 por marcolopes.
O tópico foi bloqueado.

Upgrade 9.1.1 para 9.2.1 09 Ago. 2013 03:26 #6232

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5361
  • Obrigado recebido 745
paulinomt escreveu:
Fiz backup da bd , removi o visualizador Saft e o RCP. Instalei a nova versão e o visualizador SAFT, tal como fiz no mes passado na migração da versao 8 para a 9 e que ocorreu sem problemas, tentei arrancar o RPC e dá a msg " Não é possível inicializar a persistência"

Instalei o sw do H2 para analisar alguma corrupção na BD, esta abre sem qualquer problema.
Desinstalei tudo e voltei a instalar a versão 9.1.1 e uma copia da BD não mexida pela 9.2.1 e dá o mesmo problema.

Caro Paulino,

A informática tem destas coisas, portanto, basta usar a lógica para chegarmos a uma conclusão. Siga estes passos EXACTOS e diga-me em que ponto ficou.

1) Instale a versão 9.2.1 e arranque com a aplicação. A base de dados foi CRIADA e pode trabalhar com a aplicação?
a) SIM = Feche a aplicação e siga para o ponto 2
b) NÃO = Problema na sua instalação? no sistema operativo?...

2) Copie a base de dados da versão 9.1.1 para a pasta da versão 9.2.1, SUBSTITUINDO a base de dados existente (colibri9.h2.db), e arranque com a aplicação. A base de dados foi CONVERTIDA e pode trabalhar com a aplicação?
a) SIM = Problema resolvido!
b) NÃO = Envie-me a base de dados em formato ZIP ou RAR para Este endereço de email está protegido contra piratas. Necessita ativar o JavaScript para o visualizar. para análise.
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 09 Ago. 2013 03:26 por marcolopes.
O tópico foi bloqueado.
The following user(s) said Thank You: paulinomt

Upgrade 9.1.1 para 9.2.1 08 Ago. 2013 21:10 #6229

  • paulinomt
  • Avatar de paulinomt
  • Offline
  • Mensagens: 3
Boa noite.

SO: windows 7 32bits
Upgrade do Colibri 9.1.1 para a versão 9.2.1
motor H2
Ficheiro de Log não é criado após a migração, fica o fim da versão anterior
!ENTRY colibri.rcp 0 0 2013-07-28 21:40:03.245
!MESSAGE Utilizador=admin, Verificar Actualização=Existe uma nova versão disponível (9.2.0)
!SESSION 2013-08-08 22:09:14.406 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_21
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=pt_PT
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY colibri.rcp 0 0 2013-08-08 22:10:39.797
!MESSAGE Utilizador=admin, Verificar Actualização=Existe uma nova versão disponível (9.2.1)

!ENTRY colibri.rcp 0 0 2013-08-08 22:12:10.081
!MESSAGE Utilizador=admin, Download de Actualização=Operação concluída

Fiz backup da bd , removi o visualizador Saft e o RCP. Instalei a nova versão e o visualizador SAFT, tal como fiz no mes passado na migração da versao 8 para a 9 e que ocorreu sem problemas, tentei arrancar o RPC e dá a msg "Não é possível inicializar a persistência"

Instalei o sw do H2 para analisar alguma corrupção na BD, esta abre sem qualquer problema.
Desinstalei tudo e voltei a instalar a versão 9.1.1 e uma copia da BD não mexida pela 9.2.1 e dá o mesmo problema.

Alguma sugestão?

Atentamente,
MPaulino
Última Edição: 16 Ago. 2013 13:32 por marcolopes.
O tópico foi bloqueado.
Moderadores: marcolopes
Desenvolvido por Kunena