Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: Não foi possível estabelecer a ligação

Não foi possível estabelecer a ligação 28 Ago. 2013 15:38 #6319

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5398
  • Obrigado recebido 751
SandraPereira escreveu:
Entretanto tentei fazer algumas experiências e uma delas foi seguir a instalação normal do Colibri 9 pelo que foi criada nova base de dados colibri9.h2 com USERNAME "sa" e PASSWORD (espaço em branco). Neste momento mantém-se o erro de acesso.

Repare, a cada INSTALAÇÃO do Colibri, é criado um ficheiro EMPRESAS.XML que contém UMA empresa (H2 Integrado). Esta empresa é DEFINIDA com as seguintes credênciais de base de dados:
USERNAME=sa
PASSWORD=(VAZIO) - SEM QUALQUER ESPAÇO, pois UM ESPAÇO é UM CARACTERE

Se efectuou uma NOVA INSTALAÇÃO e NÃO editou a configuração da empresa (isto é, NÃO ALTEROU o USERNAME ou PASSWORD da base de dados) tem de conseguir efectuar um LOGIN.
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 28 Ago. 2013 15:44 por marcolopes.
O adminstrador desactivou a escrita pública.

Não foi possível estabelecer a ligação 28 Ago. 2013 14:45 #6318

  • SandraPereira
  • Avatar de SandraPereira
  • Offline
  • Mensagens: 3
Desde já agradeço a atenção. Como tinha dito anteriormente, os dados mantiveram-se pelo que o USERNAME e PASSWORD não foram alterados.

No processo de desinstalação do Colibri 8 foram eliminados todos os ficheiros e/ou documentos menos o colibri8.h2 pois nas indicações dadas só este deveria ser mantido.

Entretanto tentei fazer algumas experiências e uma delas foi seguir a instalação normal do Colibri 9 pelo que foi criada nova base de dados colibri9.h2 com USERNAME "sa" e PASSWORD (espaço em branco). Neste momento mantém-se o erro de acesso. Acedendo ao documento Empresas.xml:
<?xml version="1.0" encoding="UTF-8" ?> 
- <emp:empresas-database xmlns:emp="empresas.xml.colibri.rcp">
- <emp:empresa>
  <emp:nome>Expoentemático, Unipessoal Lda.</emp:nome> 
  <emp:obs /> 
  <emp:data>2013-08-27+01:00</emp:data> 
- <emp:dbcolibri>
  <emp:driver>H2</emp:driver> 
  <emp:host /> 
  <emp:database>colibri9</emp:database> 
  <emp:utilizador>sa</emp:utilizador> 
  <emp:password /> 
  </emp:dbcolibri>
  </emp:empresa>
  </emp:empresas-database>

penso que se confirma que o USERNAME é "sa" e que a PASSWORD é (espaço em branco) tal como os que são inseridos na janela inicial para iniciar o Colibri. Será que me pode esclarecer o motivo do mesmo erro? "Não foi possével estabelecer a ligação. Wrong username or password [28000-169]"

Obrigada.
Última Edição: 28 Ago. 2013 15:28 por marcolopes.
O adminstrador desactivou a escrita pública.

Não foi possível estabelecer a ligação 27 Ago. 2013 16:52 #6313

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5398
  • Obrigado recebido 751
SandraPereira escreveu:
No entanto, quer na instalação do Colibri 8 quer no Colibri 9, limitei-me a seguir as indicações do manual de instalação pelo que o USERNAME e PASSWORD deveria ser o mesmo já que ambos os dados ficaram tal como está no manual não tendo sido feita qualquer alteração (Utilizador: sa Password: em branco).

Cara Sandra,

Com certeza definiu um outro UTILIZADOR e / ou PASSWORD na criação da base de dados.
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 14 Out. 2013 15:59 por marcolopes.
O adminstrador desactivou a escrita pública.

Não foi possível estabelecer a ligação 27 Ago. 2013 14:53 #6312

  • SandraPereira
  • Avatar de SandraPereira
  • Offline
  • Mensagens: 3
Boa tarde.

Foi necessário atualizar a versão 8 do Colibri para a versão 9. Segui todos os passos, fiz cópia de segurança do ficheiro colibri8.h2 e já a inseri na pasta do Colibri 9 com a devida atualização do nome, ou seja, para colibri9.h2.

Depois de seguir todas as indicações obtenho o mesmo erro que já foi exposto "Não foi possével estabelecer a ligação. Wrong username or password [28000-169]" e já foi possível verificar a vossa resposta: "Só você sabe que USERNAME e PASSWORD colocou na criação da base de dados... Lembre-se que os dados relativos à base de dados NADA têm a haver com os dados relativos ao LOGIN."

No entanto, quer na instalação do Colibri 8 quer no Colibri 9, limitei-me a seguir as indicações do manual de instalação pelo que o USERNAME e PASSWORD deveria ser o mesmo já que ambos os dados ficaram tal como está no manual não tendo sido feita qualquer alteração (Utilizador: sa Password: em branco).

Será que me podem ajudar nesta questão, por favor?

Obrigada pela atenção.
Sandra Pereira
Última Edição: 27 Ago. 2013 16:46 por marcolopes.
O adminstrador desactivou a escrita pública.

Não foi possível estabelecer a ligação 16 Jul. 2013 16:30 #6056

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5398
  • Obrigado recebido 751
jbatista escreveu:
o que acontece neste momento e após já ter corrigido o nome da empresa é que não consigo estebelecer ligação com a bd devido ao erro "Não foi possivél estabelecer a ligação. Wrong username or password [28000-169]".

p.f. leia este tópico.
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

Não foi possível estabelecer a ligação 16 Jul. 2013 16:21 #6055

  • jbatista
  • Avatar de jbatista
  • Offline
  • Mensagens: 21
Boa tarde,

Tinha a versão 7 Free instalada e actualizei a versão 9 Free. Neste momento está instalado e transportei a base de dados antiga com o nome "colibri7.h2.db" e renomei para "colibri9.h2.db".

o que acontece neste momento e após já ter corrigido o nome da empresa é que não consigo estebelecer ligação com a bd devido ao erro "Não foi possivél estabelecer a ligação. Wrong username or password [28000-169]".

Será que me podem ajudar a resolver esta questão?

Grato pela atenção
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes
Desenvolvido por Kunena