Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: Username e password da base de dados

Username e password da base de dados 31 Mar. 2017 23:05 #11108

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5361
  • Obrigado recebido 745
Daniel Ferreira escreveu:
Desculpem estar-me a meter outra vez.
Fiz uma experiência repetindo os mesmos passos do Pedro Sousa e dá-me o mesmo erro. Atenção, foi só nesta experiência. No meu caso tem tudo funcionado correctamente (o diabo seja cego,surdo,mudo e paralitico).
Questão: Tem a certeza que na instalação da 9.4.3 mudou o nome de utilizador e password no ecrã de login? No ficheiro empresas.xml da 9.4.3 o utilizador não estará "sa"? E experimentando fazer a instalação da versão 11, mas sem alterar o utilizador e password no ecrã de login?
Partindo de principio que não alterou a password, o utilizador em 11 tem que ser igual ao utilizador do ficheiro empresas.xml 9.4.3.
Se está tudo bem com a 9.4.3, óbviamente que é nesta conjugação utilizador/username que está o problema.
Desculpem mais uma vez, só gostaria de ajudar.

Está resolvido! O ficheiro EMPRESAS.XML enviado inicialmente para análise NÃO era o ficheiro da versão 9... daí a confusão... (onde é que o Pedro foi buscar o ficheiro é que não sei...)

Também testei o processo de upgrade que correu perfeitamente.

Estas situações geralmente são "erros" simples... que geram grandes confusões!
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 31 Mar. 2017 23:06 por marcolopes.
O adminstrador desactivou a escrita pública.
The following user(s) said Thank You: Pedro Sousa

Username e password da base de dados 31 Mar. 2017 21:01 #11107

  • Daniel Ferreira
  • Avatar de Daniel Ferreira
  • Offline
  • Mensagens: 58
  • Obrigado recebido 40
Desculpem estar-me a meter outra vez.
Fiz uma experiência repetindo os mesmos passos do Pedro Sousa e dá-me o mesmo erro. Atenção, foi só nesta experiência. No meu caso tem tudo funcionado correctamente (o diabo seja cego,surdo,mudo e paralitico).
Questão: Tem a certeza que na instalação da 9.4.3 mudou o nome de utilizador e password no ecrã de login? No ficheiro empresas.xml da 9.4.3 o utilizador não estará "sa"? E experimentando fazer a instalação da versão 11, mas sem alterar o utilizador e password no ecrã de login?
Partindo de principio que não alterou a password, o utilizador em 11 tem que ser igual ao utilizador do ficheiro empresas.xml 9.4.3.
Se está tudo bem com a 9.4.3, óbviamente que é nesta conjugação utilizador/username que está o problema.
Desculpem mais uma vez, só gostaria de ajudar.
Última Edição: 31 Mar. 2017 21:24 por Daniel Ferreira.
O adminstrador desactivou a escrita pública.
The following user(s) said Thank You: marcolopes, Pedro Sousa

Username e password da base de dados 31 Mar. 2017 17:59 #11106

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5361
  • Obrigado recebido 745
Pedro Sousa escreveu:
Boa tarde de novo Marco,
Sim, consigo entrar e utilizar normalmente a versão 9.4.3 com a base de dados que tenho tentado usar na versão 11 (renomeada).
Agora é que me está a deixar mesmo preocupado...

Então vamos fazer o seguinte para esclarecer este assunto de uma vez:

Envie-me a base de dados da versão 9 compactada em formato RAR por email, ou através de WeTransfer para eu analisar.
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

Username e password da base de dados 31 Mar. 2017 17:55 #11105

  • Pedro Sousa
  • Avatar de Pedro Sousa
  • Offline
  • Mensagens: 13
  • Obrigado recebido 1
Boa tarde de novo Marco,

Sim, consigo entrar e utilizar normalmente a versão 9.4.3 com a base de dados que tenho tentado usar na versão 11 (renomeada).

Agora é que me está a deixar mesmo preocupado...
O adminstrador desactivou a escrita pública.

Username e password da base de dados 31 Mar. 2017 17:11 #11104

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5361
  • Obrigado recebido 745
Pedro Sousa escreveu:
Vou detalhar os passos que efetuei para que não passe nada em branco:

Instalei o Projeto Colibri 11
Corri o programa
No login, mudei o username e a password (em H2 integrado, Base de Dados). Fiz "Gravar".
No utilizador "admin" coloquei a password "admin"
Entrei com sucesso no programa com a base de dados original.
Fechei o programa.
Apaguei o ficheiro colibri11.h2.db da pasta ProjectoColibriRCP11
Copiei o ficheiro colibri9.h2.db que está a funcionar corretamente na versão 9.4.3, que é a que utilizo.
Renomeei para colibri11.h2.db
Corro o Colibri (verifico que o utilizador no H2 integrado é o meu)
No utilizador "admin" coloquei a password "admin"
Faço Login e aparece-me Wrong user name or password (28000-169).

Depois disto já tentei apagar apenas o empresas.xml, apenas o colibri11.h2.db, ambos os ficheiros.
Até tentei substitui o colibri11.h2.db com o programa em funcionamento mas nunca tive sucesso.
Tentei também a instalação como administrador no computador.

Estou a entrar em parafuso.

Caro Pedro... pelo que me descreve também NÃO PODE estar a conseguir entrar no programa na versão 9!!!

Na versão que TEM instalada (antiga) consegue fazer o LOGIN?? Não pode!!!
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

Username e password da base de dados 31 Mar. 2017 14:19 #11103

  • Pedro Sousa
  • Avatar de Pedro Sousa
  • Offline
  • Mensagens: 13
  • Obrigado recebido 1
Boa tarde novamente Marco (agora no tópico certo),

Parece mesmo bruxedo mas continuo a não conseguir entrar no programa com a minha base de dados.
Segui as instruções que o Marco me deu:


"Aconselho que faça o que já lhe disse: apague o ficheiro EMPRESAS.XML e deixe o colibri criar um novo.
EDITE a EMPRESA criada, e no separador de base de dados coloque:
UTILIZADOR = ***
PASSWORD = ***

Copie a base de dados da versão anterior, mude o nome para colibri11.h2 e o programa TEM de arrancar devidamente!!!"



Vou detalhar os passos que efetuei para que não passe nada em branco:

Instalei o Projeto Colibri 11
Corri o programa
No login, mudei o username e a password (em H2 integrado, Base de Dados). Fiz "Gravar".
No utilizador "admin" coloquei a password "admin"
Entrei com sucesso no programa com a base de dados original.
Fechei o programa.
Apaguei o ficheiro colibri11.h2.db da pasta ProjectoColibriRCP11
Copiei o ficheiro colibri9.h2.db que está a funcionar corretamente na versão 9.4.3, que é a que utilizo.
Renomeei para colibri11.h2.db
Corro o Colibri (verifico que o utilizador no H2 integrado é o meu)
No utilizador "admin" coloquei a password "admin"
Faço Login e aparece-me Wrong user name or password (28000-169).

Depois disto já tentei apagar apenas o empresas.xml, apenas o colibri11.h2.db, ambos os ficheiros.
Até tentei substitui o colibri11.h2.db com o programa em funcionamento mas nunca tive sucesso.
Tentei também a instalação como administrador no computador.

Estou a entrar em parafuso.

O Marco deteta algum erro neste procedimento?
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes
Desenvolvido por Kunena