Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: Ligação base de dados PostgreSQL

Ligação base de dados PostgreSQL 18 Jun. 2017 06:05 #11247

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5407
  • Obrigado recebido 753
Cabral escreveu:
Não consigo recuperar o backup da base de dados entretanto criada do colibri10 para a nova base de dados que criei o colibri11
Vou ao pgAdmin III, para ir à base de dados colibri10 e faço o backup e fico com um ficheiro com a extensão .backup. Depois no pqAdmin III crio uma nova base de dados com o nome colibri11. Depois de criada, tento fazer a recuperação. Escolho o ficheiro, mas o botão de "restore" não fica activo para continuar.

O tópico correcto é este: projectocolibri.com/forum/bases-de-dados...-de-dados-postgresql

Já lá falamos sobre o assunto...
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.
The following user(s) said Thank You: Cabral

Ligação base de dados PostgreSQL 16 Jun. 2017 11:11 #11244

  • Cabral
  • Avatar de Cabral
  • Offline
  • Mensagens: 66
  • Obrigado recebido 7
Não consigo recuperar o backup da base de dados entretanto criada do colibri10 para a nova base de dados que criei o colibri11

Vou ao pgAdmin III, para ir à base de dados colibri10 e faço o backup e fico com um ficheiro com a extensão .backup. Depois no pqAdmin III crio uma nova base de dados com o nome colibri11. Depois de criada, tento fazer a recuperação. Escolho o ficheiro, mas o botão de "restore" não fica activo para continuar.
Última Edição: 16 Jun. 2017 11:54 por Cabral. Motivo: adicionei mais informação
O adminstrador desactivou a escrita pública.

Ligação base de dados PostgreSQL 20 Fev. 2017 18:51 #11005

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5407
  • Obrigado recebido 753
luis soldado escreveu:
Após tentar a ligação através do ícon "serviços" no Painel de controlo, aparece a janela que envio em anexo.

Não faço ideia das razões para que o serviço não inicie... o meu conselho é que desinstale completamente o PostgreSQL e volte a instalar a partir da package de instalação.

FAÇA PRIMEIRO pelo menos 2 CÓPIAS de SEGURANÇA!!!!

- Uma cópia da base de dados a partir das opções do Colibri (ecrã de LOGIN -> EMPRESAS -> BACKUP) e verifique se o ficheiro foi correctamente criado na pasta indicada para os backups (geralmente C:\ProjectoColibriRCPXX\backups)
- Uma cópia da PASTA da instalação ACTUAL do PostgreSQL (pode compactar) por forma a poder ter acesso aos dados em caso de problemas.

Pode encontrar mais informação sobre backups neste tópico: projectocolibri.com/forum/faq-perguntas-...cos-da-base-de-dados

Se necessitar de ajuda, p.f. contacte o nosso suporte técnico via telefone.
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 20 Fev. 2017 18:54 por marcolopes.
O adminstrador desactivou a escrita pública.

Ligação base de dados PostgreSQL 06 Fev. 2017 13:37 #10966

  • luis soldado
  • Avatar de luis soldado
  • Offline
  • Mensagens: 7
Após tentar a ligação através do ícon "serviços" no Painel de controlo, aparece a janela que envio em anexo.

Cumprimentos,

Luís Soldado
Anexos:
Última Edição: 20 Fev. 2017 18:46 por marcolopes.
O adminstrador desactivou a escrita pública.

Ligação base de dados PostgreSQL 19 Fev. 2014 12:22 #7482

  • Ricardo
  • Avatar de Ricardo
  • Offline
  • Mensagens: 13
quando faço o login aparece um erro a dizer que nao foi possivel estabelecer a ligação. FATAL:password authentication failed for user "postgres"

alguem me pode ajudar ?
O adminstrador desactivou a escrita pública.

Ligação base de dados PostgreSQL 08 Fev. 2014 17:35 #7430

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5407
  • Obrigado recebido 753
Ricardo escreveu:
Hoje como qualquer outro dia ia a abrir o colibri e deu-me esta mensagem de erro.
"Não foi possivel estabelecer ligação
Connection refused. Check the hostname and port are correct and the postmaster is accepting TCP/IP connections"
Não alterei nada de ontem para hoje.

Não me diz que MOTOR de dados está a utilizar.

Pela mensagem de erro, vou "deduzir" que se trata do PostgreSQL.

Tem a certeza que o MOTOR de dados está a correr? Parece-me que o serviço relativo ao PostgreSQL está desligado.
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes
Desenvolvido por Kunena