Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: API da versão 12

API da versão 12 1 mês 2 semanas atrás #11782

  • marcolopes
  • Avatar de marcolopes
  • DESLIGADO
  • Mensagens: 4826
  • Obrigado recebido 671
API 12.1.3 foi publicada (GitHub): github.com/projectocolibri/api/releases

O projecto org.projectocolibri.rcp passa a estar dividido em 4 plugins:

- org.projectocolibri.drivers (database / poolmanager DRIVERS)
- org.projectocolibri.api (reports / database / webservices API)
- org.projectocolibri.ui.login (LOGIN user interface)
- org.projectocolibri.rcp (COLIBRI user interface)

Projectos de EXEMPLO (actualizados): github.com/projectocolibri/api

O projecto org.projectocolibri.rcp.example passa a estar dividido em 2 plugins:

- org.projectocolibri.api.example (depende de org.projectocolibri.api, e não implementa qualquer interface)
- org.projectocolibri.rcp.example (depende de org.projectocolibri.api, org.projectocolibri.rcp e org.projectocolibri.api.example)

Documentação (Wiki): github.com/projectocolibri/api/wiki

1.Instalação
2.Configuração
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 1 mês 2 semanas atrás por marcolopes.
O adminstrador desactivou a escrita pública.

API da versão 12 1 mês 2 semanas atrás #11813

  • anakin84
  • Avatar de anakin84
  • DESLIGADO
  • Mensagens: 18
  • Obrigado recebido 1
Boa noite,


A documentação está desactualizada (desde links a versões necessárias).

A versão do eclipse que está na documentação contém a versão do eclipse jface 3.7, mas o colibri precisa da versão 3.8.

Qual a versão base do eclipse? É possível actualizar a restante documentação?

Obrigado.


Cumprimentos
O adminstrador desactivou a escrita pública.

API da versão 12 1 mês 2 semanas atrás #11814

  • marcolopes
  • Avatar de marcolopes
  • DESLIGADO
  • Mensagens: 4826
  • Obrigado recebido 671
anakin84 escreveu:
Boa noite,
A documentação está desactualizada (desde links a versões necessárias).
A versão do eclipse que está na documentação contém a versão do eclipse jface 3.7, mas o colibri precisa da versão 3.8.
Qual a versão base do eclipse? É possível actualizar a restante documentação?

A documentação está actualizada. Na página principal da WIKI está lá o link para os "drops" do eclipse 3.8 (versão que deve ser utilizada com a API 12): archive.eclipse.org/eclipse/downloads/dr...-3.8.2-201301310800/

Ainda assim, o que deve ter em conta é o que está na página de instalação:

Instalar "Eclipse Indigo for RCP and RAP Developers". Efectuar o download em www.eclipse.org/downloads/packages/eclip...developers/indigosr2; Descompactar em /eclipse

O link aqui apresentado é relativo à versão RCP 3.8 SR2 (3.8.2), cuja página principal (todas as releases desta versão) é: eclipse.org/downloads/packages/release/Indigo/SR2

Não posso precisar, mas as packages RCP estão todas já actualizadas para a versão 3.8.2, ainda assim, pode fazer um Help -> Check for Updates (depois ter ter o IDE instalado)
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes