Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: API da versão 10

API da versão 10 18 Dez. 2014 16:57 #8457

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5431
  • Obrigado recebido 754
inforoeste escreveu:
Não consigo por os novos projectos de exemplo da api 10 a funcionar por mais que tente seguir os passos da instalação tenho sempre problemas no ficheiro MANIFEST.MF a dependencia "org.projectocolibri.rcp (10.0.0)" nunca é resolvida.

EDIT: Notei que também estou a ter problemas do tipo "Unsatisfied version constraint" nas seguintes linhas do manifest.mf:
org.eclipse.ui;bundle-version="3.8.2",
org.eclipse.core.runtime;bundle-version="3.8.0"

A versão 10 foi desenvolvida sobre Eclipse INDIGO 3.8, que no fundo é um pequeno update do 3.7, e não deveriam haver problemas em correr a API sobre qualquer uma das versões.

Estou a analisar, e efectivamente tenho o mesmo problema com o reconhecimento das dependências "org.projectocolibri.*" o que é estranho.

Se não chegar a qualquer conclusão rápidamente, irei criar um PACK de base com o Eclipse 3.8 e colocar para download.
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 18 Dez. 2014 17:11 por marcolopes.
O adminstrador desactivou a escrita pública.

API da versão 10 18 Dez. 2014 13:15 #8452

  • inforoeste
  • Avatar de inforoeste
  • Offline
  • Mensagens: 39
  • Obrigado recebido 14
Boa tarde

Não consigo por os novos projectos de exemplo da api 10 a funcionar por mais que tente seguir os passos da instalação tenho sempre problemas no ficheiro MANIFEST.MF a dependencia "org.projectocolibri.rcp (10.0.0)" nunca é resolvida.

Também verifiquei que descompactei correctamente os dropins do datanucleus e do colibri 10.0.7 para a pasta dropin do eclipse.

Esta situação não me acontecia com a api 9 e tentei seguir os passos todos novamente numa máquina diferente e estou sempre com este problema, o que poderá ser?

EDIT: Notei que também estou a ter problemas do tipo "Unsatisfied version constraint" nas seguintes linhas do manifest.mf:
org.eclipse.ui;bundle-version="3.8.2",
org.eclipse.core.runtime;bundle-version="3.8.0",

Se não estou em erro a versão 3.8 do eclipse é a Juno no entanto o tutorial fala para usar a Indigo, o tutorial de instalação continua actualizado face a nova api?

Atentamente
Última Edição: 18 Dez. 2014 16:55 por marcolopes.
O adminstrador desactivou a escrita pública.
The following user(s) said Thank You: marcolopes

API da versão 10 12 Dez. 2014 01:04 #8419

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5431
  • Obrigado recebido 754
A API da versão 10.0.7 está disponível no Googlecode: code.google.com/p/projectocolibri/

- Esta versão assenta numa completa revisão interna (foram analisados centenas de pontos), que resulta uma melhoria significativa de performance em muitas operações e uma API muito mais eficiente e simplificada (a partir da qual foi implementado o novo módulo WEB).

- O projecto de exemplo foi revisto e actualizado e deve ser consultado / utilizado como base para novos projectos ou para dissipar dúvidas relativamente à utilização da API: code.google.com/p/projectocolibri/source...ocolibri.rcp.example
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 12 Dez. 2014 01:05 por marcolopes.
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes
Desenvolvido por Kunena