Bem-vindo, Visitante
Nome do utilizador: Senha: Memorizar

TÓPICO: Configuração dos projectos

Configuração dos projectos 31 Jan. 2013 19:20 #4404

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5348
  • Obrigado recebido 743
RRocha escreveu:
Em parte concordo.
Noutra parte confesso ser relativo. Sendo presente um ambiente Eclipse/Java, não é assim tão simples alguem que vem do Visual Studio adaptar-se. A minha sugestão prendeu-se apenas com um QuickStart da API Colibri, apenas isso.

Esta sugestão será tomada em conta!

Quanto à questão do tópico, essa sim a ser discutida, volto a dizer que não deve existir necessidade de configurar absolutamente mais nada para que os projectos não apresentem erros. Portanto, acabamos por não chegar a uma conclusão sobre o que pode estar a causar problemas.

A adição e remoção de plugins através das OPÇÕES do ECLIPSE existentes para o efeito NÃO PODEM adulterar as configurações do projecto, nem interferir nos plugins existentes... aliás, provei-o ao instalar todos os plugins disponíveis na categoria WEB
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

Configuração dos projectos 31 Jan. 2013 10:01 #4394

  • RRocha
  • Avatar de RRocha
  • Offline
  • Mensagens: 31
  • Obrigado recebido 2
Em parte concordo.
Noutra parte confesso ser relativo. Sendo presente um ambiente Eclipse/Java, não é assim tão simples alguem que vem do Visual Studio adaptar-se. A minha sugestão prendeu-se apenas com um QuickStart da API Colibri, apenas isso.

Quanto ao problema:
efectivamente a instação de plugins leva a uma situação de erro ao tentar executar. Tal como eu coloquei num tópico anterior acerca do log4j, e ficando para referência, para que o projecto pudesse executar correctamente (no example) tive de acrescentar a seguinte linha ao ficheiro log4j.properties "log4j.rootLogger=debug,A1"

Tive de colocar tbm cópia deste ficheiro na pasta \src

Se isto faz sentido ou não, sinceramente não sei, pois so depois de fazer isto o programa deixou de dar a mensagem de aviso. Fica para referência se alguem tiver problemas.

Desde já as minhas desculpas sobre tanta mensagem de tanto problema, mas acredito neste projecto e pretendo usa-lo em mais clientes da empresa onde estou.

Obrigado.
O adminstrador desactivou a escrita pública.

Configuração dos projectos 30 Jan. 2013 21:38 #4371

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5348
  • Obrigado recebido 743
RRocha escreveu:
Uma vez ter conseguido instalar, poderia-lhe pedir para proceder da mesma forma quanto à disponibilização? Assim à semelhança da primeira vez quase de certeza que não terei problemas com os addons para o tomcat e o axis. Seria uma boa ideia, e apenas sugestão, disponibilizar um download assim, como que um quick start para a api.

A disponibilização do Eclipse já com a API teve um objectivo de "despiste" que provou que não é uma configuração do seu PC (ex: Java) que estaria a causar o problema de instalação da API, uma vez que bastou descompactar o ambiente que criei e verificar que não existiam erros.

O Eclipse tem tudo o que é necessário dentro da pasta enviada. Configurei TUDO de RAIZ, até mesmo o Download do site do Eclipse!

Portanto, não faz grande sentido efectuar mais nenhum PACK, mas sim chegar a uma conclusão sobre o que pode estar a causar o problema, caso contrário, estará sempre dependente de um ambiente pré-existente, sem poder instalar / remover plugins, o que não tem qualquer lógica!
Marco Lopes
Gestor de projecto
Análise e Programação
Última Edição: 30 Jan. 2013 21:39 por marcolopes.
O adminstrador desactivou a escrita pública.

Configuração dos projectos 30 Jan. 2013 09:53 #4348

  • RRocha
  • Avatar de RRocha
  • Offline
  • Mensagens: 31
  • Obrigado recebido 2
Eu pegando no zip que disponibilizou, extrair, abrir e compilar o projecto -> OK abre. Logo após, selecciono o repositorio indigo > web > selecciono os elementos a instalar.
Só me apercebi qual era, após começar a instalar um a um.

1 - Há alguma configuração necessária extra eclipse que tenha configurado? Variáveis de ambiente p ex? acho estranho como conseguiu sempre fazer isso e na minha máquina estoura à minima alteração.

2 - Quando eu instalo os plugins, ao executar o projecto, o colibri dá me a seguinte mensagem: "Não foi possível iniciar a persistência". Assim como na console algo começado por:
log4j:WARN No appenders could be found for logger (DataNucleus.Plugin).
log4j:WARN Please initialize the log4j system properly.
Failed to instantiate SLF4J LoggerFactory
Reported exception:
java.lang.NoClassDefFoundError: org/apache/log4j/Level
at org.slf4j.LoggerFactory.bind(LoggerFactory.java:121)

3 - Uma vez ter conseguido instalar, poderia-lhe pedir para proceder da mesma forma quanto à disponibilização? Assim à semelhança da primeira vez quase de certeza que não terei problemas com os addons para o tomcat e o axis. Seria uma boa ideia, e apenas sugestão, disponibilizar um download assim, como que um quick start para a api.

Desde já obrigado pelo suporte, tem sido proveitoso!

Cumps.
Última Edição: 30 Jan. 2013 19:22 por marcolopes.
O adminstrador desactivou a escrita pública.

Configuração dos projectos 30 Jan. 2013 01:55 #4340

  • marcolopes
  • Avatar de marcolopes
  • Offline
  • Mensagens: 5348
  • Obrigado recebido 743
RRocha escreveu:
Como o eclipse não tinha o necessário: instalei atraves do install new software um de cada vez, WDT, o JST Server adapters e extensions, ate que instalando o Eclipse Java Web Developer Tools deixo de conseguir compilar o projecto.

Acabei de testar o mesmo ambiente que enviei, adicionando
WDT
JST Server adapters e extensions
Eclipse Java Web Developer Tools

Tudo impecável, como seria de esperar... Aliás... Adicionei TODOS os plugins existentes em: Web, XML, Java EE and OSGI Enterprise Development!
Marco Lopes
Gestor de projecto
Análise e Programação
O adminstrador desactivou a escrita pública.

Configuração dos projectos 29 Jan. 2013 17:12 #4322

  • RRocha
  • Avatar de RRocha
  • Offline
  • Mensagens: 31
  • Obrigado recebido 2
Marco, resposta bastante directa ao IDE. Obrigado.
Desta forma coloco então a dúvida:
Quis no projecto de exemplo que fiz download em ZIP, criar um webservice:
Como o eclipse não tinha o necessário: instalei atraves do install new software um de cada vez, WDT, o JST Server adapters e extensions, ate que instalando o Eclipse Java Web Developer Tools deixo de conseguir compilar o projecto.

Para não complicar muito, o que o marco sugere que eu faça para poder criar um webservice com os recursos que fiz download deste topico?
Considerando que, colocar API no dropins leva me ao problema inicial deste tópico?

Muito obrigado :)
O adminstrador desactivou a escrita pública.
Moderadores: marcolopes
Desenvolvido por Kunena